Far-Cry.ru >> Данные о Far Cry -> Д.С.П. Материалы

Д.С.П. Материалы
FARCRY: Настройка и оптимизация
(FarCryConfigurator.exe)

Вступление:

Как только выходит новая игра, использующая самые последния достижения...(бла бла бла). Разумеется встает вопрос о том, как же все это дело теперь нормально запустить на своем железе и полноценно ощутить все эти красивости не теряя при этом в скорости и комфортности игры. Поэтому ко всем "большим" играм как правило появляются "сборники советов" по оптимизации. Что ж не будем отставать от жизни. Ниже вам предлагается материал, который в определенный случаях может сберечь вам нервы и помочь оптимально настроить Far Cry для вашей железяки.

Так как:

Для современных игр очень важна общая оптимизация вашей системы и любая игра будет себя неловко чуствовать в окружении всяких там резидентно сидящих в памяти программ и утилит, а также в условиях ограниченной виртуальной памяти или скажем старых драйверов.

То:

- удалите из автозагрузки всевозможные "ненужные" программы, в особенности те, которые вы сможете потом сами беспрепятственно запустить.

- обновите драйверы для видео, звука, чипсета материнской платы (например nforce2 или via pack)

- проведите дефрагментацию HDD там где установлена игра - это увеличит скорость загрузки уровней в игре.

Процесс оптимизации:

Оптимизировать Far Cry мы будем играясь с настройками FarCryConfigurator.exe из папки bin32, находящейся в дирректории Far Cry.

Далее мы рассмотрим подробно все возможные настройки с их значениями. После ознакомления с ними вы сами сможете решить хотите ли вы играть с увеличенной скоростью или все же предпочтете качество.

Схема оптимизации простая - вы заходите в конфигуратор, выбираете уровень своей машины:

low - слабая (Процессор: < 1Ghz; Видеокарта: ~Geforce3ti (Geforce4MX)

medium - средняя (Процессор: 1,7-2Ghz; Видеокарта: ~Geforce3ti, Geforce4200ti)

high - мощная (Процессор: 2-2,5Ghz; Видеокарта: ~Geforce4600ti, FX5600, FX5900)

very high - топ класс (Процессор 3,2Ghz; Видеокарта: ~GeforceFX5900, FX5950, ATI9800pro)

Затем отключая ненужные (или неважныепо вашему мнению) примочки и эффекты еще более увеличиваете производительность игры. Итак:

На этом экране (выше) можно отрегулировать параметр lazy weapon (задержка оружия), он определяет время поворота ствола оружия за поворотом направления взгляда (для большей реалистичности). На скорость игры не влияет.

Corpse stay - время через которое модельки поверженных вами будут исчезать с глаз долой. Чем больше трупов валяется на уровне тем больше тормозов. Так что для уровней с большим количеством пушечного мяса на слабых машинах его можно уменьшать (но удовольствия при этом явно меньше=)

Machine Spec - определяет набор установок под разные по производительности компютеры. Можете на обращать внимание на этот параметр так как мы все равно превратим его в custom (свой!)

Enable Gore - для ранимых и чувствительных любителей FPS (такие есть??) есть возможность выключить кровь и прочие жестокости (эмм...как бы...а в чем тогда прикол=)

Идем дальше и переходим ко второй вкладочке:

Renderer - тот графический API, который будет использоваться игрой. По умолчанию это DirectX 9. В этом конфигураторе возможность выбора других API заблокирована, но есть способ завести игру в OpenGL режиме. При этом скорость и "стабильность" графики возрастают, но: а) вы лишаетесь деколей (дырок от пуль на трупах например) б) возможны графические глюки (неправильное освещение и тп, но тут многое от драйверов зависит). Все же рекомендуем самые "тормозные" уровни проходить именно в OpenGL. Один раз попробовав его вы сразу почуствуете разницу и будете жалеть только о перечисленных выше а) и б). Для включения OpenGL - откройте для редактирования (например блокнотом) файл system.cfg в корневой папке игры. Найдите строку: r_Driver = "Direct3D9" и замените Direct3D9 на OpenGL.

Screen Resolution - разрешение экрана в игре. Традиционно чем оно выше тем меньше скорость. Но ни при каких условиях не ставьте его ниже чем 800х600! Вы почти не выиграете в скорости, зато испортите все впечатление от игры! Вообще говоря - оставляйте его на 1024х768. Современные графические карты теперь не так сильно зависят от разрешения как раньше. 32 битный цвет - понятное дело как раз для такой красоты как в тропиках и нужен!

Antialiasing - сглаживание "зубчатых" поверхностей. Рекомендуется ставить галочку только тем, у кого топовые графические карточки (FX5900 например) и мощный процессор. Сглаживание значительно снижает производительность но красота того стоит. Поэтому если в вашей тачке 3 литровый движок с турбонаддувом - почему бы нет?

Full Screen - галочка по умолчанию означает что вы будете играть на полный экран. В форточке играть? ну тогда вам лучше в сапера или в тетрис=)

Vertical Sync - интересная настройка. Привязывает прорисовку экрана вашей графической карточкой к герцовке монитора. С одной стороны плюс: изображение не "рвется" и четче картинка в динамике, НО если у вас не самая мощная машина, то вы будете ощущать "проседания" когда не справившись скажем с 85fps (ваш монитор например стоит в такой герцовке - 85hz) ваша видеокарта начнет синхронизировать каждый второй кадр, при этом fps упадут вдвое и так до тех пор пока скорости видеокарты не хватит для прорисовки всей графики с 85fps. На очень мощных машинах можно и включить.

Следующая закладка:

Представленные здесь расширенные настройки видео аналогичны тем, что вы можете изменять из главного меню игры. Большинство из них могут изменяться в диапазоне от very low (очень низко) very high (очень высоко). Справа можно выбрать предустановки на определенный уровень. Autodetect кстати не работает - не удивляйтесь что вашу машину он так невежливо занесет в список лузеров=):

Texture Quality - качество текстур. В зависимости от мощности компьютера, но не ставьте значения ниже среднего (medium) иначе качество текстур станет неприемлимым.

Texture Filter Quality - качество фильтрации текстур. Если объяснять доступнее то при билинейной (bilinear) фильтрации текстуры будут менее четкими и общая картинка не такая красивая как при трилинейной (trilinear) Но если вы не такой эстет и вам нужна производительность - оставляйте bilinear

Anisotropic Filtering Level - уровень анизотропной фильтрации (очередной технический груз=) Будем проще это как "чем он выше тем еще более четкой будет картинка в игре". Это опять таки для эстетов на мощном железе. Рекомендуем оставлять 1 (по умолчанию)

Particle Count - в игре множество эффектов основанных на частицах (пламя, дым от песка и многое другое) от количества используемых частиц зависит качество и реалистичность этих эффектов. Средний уровень (medium) дает хорошее качество, но если запас прочности вашей железки велик - смело повышайте.

Special Effects Quality - эта настройка отвечает за качество и количество специальных эффектов (например отблеск солнца от знойного песка и тп). Аналогично Particle Count - если не жалко скорости.

Environment Quality - качество "окружения". Один знакомый сказал как-то: "вот хороши подводные красоты в Far Cry, да вот что-то живности там нет..." Как нет? а ну ставьте very high - у вас под водой косяки рыб плавать будут, а по острову тучи попугаев носиться!

Shadow Quality - качество теней. Стандартно ниже среднего не ставить это табу! Тени в Far Cry это одна из его главных достопримечательностей.

Water Quality - качество воды. Конечно не в плане ее вкусовых характеристик. Эта настройка регулирует насколько реалистично будут смотреться волны на воде, отражения в воде, прибрежные барашки от воды и тп.

Lighting Quality - качество освещения. Чем оно выше тем больше вы увидите динамического освещения в игре (тем больше тормоза соответственно). Попробуйте значения high для освещения и теней и проползите под пальмой например. Тень от нее будет динамически отбрасываться на оружие в ваших руках. Ощущения совсем другие при этом и эффект присутствия усиливается.

А теперь главное зачем мы вообще полезли в этот конфигуратор - кнопочка Customize! Как раз она открывает доступ к настройкам через самые важные для нас графические консольные переменные.

Теперь после выбора уровня вашей машины вы можете настроить игру "под себя" - поотключать ненужные вам вещи и так далее.

Первая вкладка касается качества текстур. Кстати сразу отметим, поигравшись с настройками становится ясно "оригинальное" качество текстур (и по всей видимости игры в целом) достигается на настройках high! на medium например уже урезается разрешение текстур и т.п. но об этом ниже. Поэтому если хотите играть в настоящий Far Cry - апгрейдиться вам до такой тачки, чтобы без проблем играть на установках high!

r_TexResolution - разрешение текстур: 0 - оригинальное, 1 - половина оригинального (хуже) , 2 - четверть (еще хуже)

r_TexSkyResolution - разрешение текстуры неба: 0 - оригинальное, 1 - половина оригинального (хуже) , 2 - четверть (еще хуже)

r_TexBumpResolution - разрешение bumb карт (эти штуки накладываются на обычные текстуры и создают рельефность поверхностей): 0 - оригинальное, 1 - половина оригинального (хуже) , 2 - четверть (еще хуже)

e_detail_texture_quality - качество детализации для текстур. В Far Cry для большей "красивости" в режимах качества есть возможность подменять текстуру на более качественную при совсем близком приближении (значение "1") или же использовать все ту же текстуру. Тогда при приближении она будет растянутой и не такой реалистичной.

r_DetailTextures - включает оверлей (накладку) текстур для качественной работы выше описанного подмена текстур.

r_DetailNumLayers - определяет количество слоев для наложения детализированных текстур (максимум 2)

r_DetailDistance - определяет дистанцию на которой происходит попиксельное смешивание для детализированных текстур. 0 = низкое качество, 16 = очень высокое.

Далее:

Здесь все просто и менять фактически нечего. Настроить билинейное или трилинейное качество фильтрации можно и из основного меню. Пропускаем и идем дальше.

Аналогично. Анизотропную фильтрацию мы настраиваем из основного меню. Дальше:

Вкладка регулирует качество и количество частиц. Вот здесь можно более гибко подойти к вопросу оптимизации. Так как конфигуратор настраивает количество частиц увеличивая его: 512>2048>4096>8192. Ничто не мешает нам выбрать значения для e_particles_max_count равные например 3072 или 6144.

e_particles_lod - регулируют уровень детализации частиц. (значения между 0.5 > 1.0) Чем выше детализация тем качественнее смотрится дым, огонь и подобные эффекты.

А здесь можно отрегулировать работу специальных эффектов:

r_MotionBlur - эффект "кинематографичности", с включенным эффектом происходящее в динамике на экране начинает больше походить на то что мы видим в кино (это так авторы думают). На самом деле эффект еще настолько несовершенен, что его применение не совсем понятно. Можно рекомендовать отключать на всякий случай и для увеличения производительности.

r_Glare - регулирует эффект отблесков и яркости света. Изменяется в диапазоне от 0 до бесконечности.

r_GlareQuality - качество вышеописанной команды. 0 - низкое, 1 - среднее, 2 - высокое.

r_Flares - эффект линз камеры от солнца. 0 - выключен, 1 - включен.

r_checkSunVis - регулирует способ прорисовки солнца с использованием разных техник размытия и так далее. Может принимать значения от 0 (выключен) до 3. Для истинных "эстетов"=)

r_Coronas - включает (1) и выключает (0) "короны" вокруг источников света

r_CoronaFade - определяет затухание "корон". То есть интенсивность перехода света от источника в темноту. Значения от 0.0 до 1.0

r_HeatHaze - включает (1) и выключает (0) эффект испарений от жары и влажности.

r_Scopelens_fx - включает (1) и выключает (0) эффект бликов при использовании снайперских винтовок. Больной вопрос как засечь кемпера со снайперкой решен в Far Cry радикально. Теперь каждый использующий зум игрок рискует быть обнаруженным из-за бликов от его оптики.

r_ProcFlares - включает (1) и выключает (0) эффект линз.

r_CryvisionType - определяет качество (2>1>0) эффекта при использовании CryVision очков. 0 обеспечивает лучшее качество.

r_DisableSfx - включает (1) и выключает (0) дополнительные спецэффекты (эх знать бы какие=)

r_Beams - включает (1) и выключает (0) эффекты лучей (разведка не докладывает какие из эффектов относятся к лучевым но с этим работаем=)

es_EnableCloth - включает одежду как физический объект. Звучит странно но так и есть в этом случае одежда (броники и прочее на персонажах становится таким же объектом игрового мира как и сам персонаж, на нее могут действовать те же силы и законы игровой физики) Сильнее нагружает процессор, однако ведет к большей реалистичности.

Эффекты окружающего мира и количество фауны можно отрегулировать во вкладке Environment Quality. Здесь можно найти много интересных вещей:

r_VolumetricFog - включает (1) и выключает (0) объемный туман (более реалистичный)

r_EnvCMResolution - регулирует разрешение для кубических карт окружения: 0 - 64 пикселя, 1 - 128 пикселей, 2 - 256 пикселей.

r_EnvCMupdateInterval - интервал обновлений для кубических карт окружения: от 0.001 до 1.0

r_EnvTexResolution - Разрешение для двухмерных текстур окружения: 0 - 64 пикселя, 1 - 128 пикселей, 2 - 256 пикселей, 3 - 512 пикселей.

r_EnvTexUpdateInterval - интервал обновлений для двухмерных карт окружения: от 0.001 до 1.0

e_decals - включает (1) и выключает (0) деколи (дырки от пуль и тп)

e_decals_life_time_scale - определяет "время жизни" деколей (сколько они будут оставаться на карте). Значения от 0,5 до бесконечности.

ca_EnableDecals - включает (1) и выключает (0) деколи (дырки от пуль, кровь ) на персонажах

e_overlay_geometry - включает (1) и выключает (0) геометрию наложения для более сложных и реалистичных поверхностей.

e_obj_lod_ratio - уровень детализации для объектов, растительности и тп. от 5 до бесконечности.

e_vegetation_sprites_distance_ratio - регулирует расстояние на котором объекты растительности подменяются простыми спрайтами. От 0,9 до бесконечности.

e_cgf_load_lods - включает (1) и выключает (0) подгрузку моделей с уменьшенной детализацией для увеличения скорости.

e_vegetation_min_size - минимальный размер растительности считающийся достаточным для его вывода на экран. Можно отрегулировать такчтобы не было травы например. (от 0 до бесконечности)

e_flocks - включает (1) и выключает (0) стаи птиц и косяки рыбы

e_EntitySuppressionLevel - определяет уровень начиная с которого будут прорисовываться объекты. Объекты с уровнем ниже этого прорисовываться не будут. (от 0 до бесконечности)

sys_skiponlowspec - устраняет загрузку сложных объектов для слабых машин (1). Для мощных рекомендуется оставлять опцию выключенной (0).

Теперь посмотрим как регулируется качество теней:

e_stencil_shadows - включает (1) и выключает (0) использование стенсил теней (более реалистичные)

e_shadow_maps - включает (1) и выключает (0) использование карт теней

e_active_shadow_map_receiving - позволяет объектом принимать тень от всех активных карт теней. 0 - функция выключена, 1 - включена, 2 включена с еще лучшим качеством.

r_ShadowBlur - включает (1,2,3) и выключает (0) использование размытия границ теней. Цифры определяют метод размытия.

e_shadow_maps_view_dist_ratio - дальность видимости с которой начинают учитываться карты теней. (от 10 до бесконечности, но чем дальше тем сильнее нагрузка на ресурсы)

А теперь коснемся воды:

r_WaterRefractions - включает (1) и выключает (0) рельефность водной поверхности

r_WaterReflections - включает (1) и выключает (0) отражения в водной поверхности

r_WaterUpdateFactor - устанавливает частоту обновления для отражений. (от 0.001 до 1.0)

r_Quality_Reflection - включает (1) и выключает (0) отражения всего включая объекты в воде (сильно нагружает ресурсы)

e_beach - включает (1) и выключает (0) анимацию волн на берегу (без них смотрится убого на самом деле)

e_use_global_fog_in_fog_volumes - включает (1) и выключает (0) подводный туман (мутность толщи воды)

Ну и наконец добрались до вкладки с освещением. Которое кстати одно из самых ресурсоемких.

r_Quality_BumpMapping - включает bumpmapping и определяет его качество. Bumpmapping это как раз то что придает поверхностям и текстурам натуральный вид (шершавые на ощупь стены и тп) 0 - выключает, 1 - низкое качество, 2 - среднее, 3 - высокое.

r_Vegetation_PerpixelLight - включает (1) и выключает (0) попиксельное освещение для объектов растительности (больше красоты но меньше скорость)

e_light_maps_quality - определяет качество карт освещения. 0 - низкое качество, 1 - среднее, 2 - высокое.

ca_ambient_light_intensity - определяет интенсивность дополнительного направленного света. От 0 до 1.0.

ca_ambient_light_range - определяет присутствие дополнительного направленного света (от 0 до бесконечности)

e_max_entity_lights - определяет максимальное количество источников света для одного объекта. (от 0 до бесконечности)

e_stensil_shadows_only_from_strongest_light - включает (1) наличие только одной стенсил тени от одного объекта (для экономии производительности, мощные машины могут справится и с несколькими)

p_lightrange - расстояние на которое бьет фонарик игрока (от 0 до бесконечности)

r_EnvLightCMSize - определяет размер кубических карт для создания псевдо излучений (может принимать значения 2,4,8,16,32,64)

r_EnvLCMupdateInterval - интервал между обновлениями кубических карт для псевдо излучений (от 0.001 до 1.0)

cl_projectile_light - включает (1) и выключает (0) динамическое освещение для трасеров пуль и тп.

cl_weapon_light - включает (1) и выключает (0) динамическое освещение для оружия. 2 - обеспечивает более высокое качество.

Со светом покончили. Остался еще один немаловажный аспект настройки, а именно - звук.

В Far Cry звук на самом деле "решает"! А мощный движок с динамическими музыкальными темами реально работает создавая атмосферу напряжения.

Что же у нас со звуком?

Speaker Setup - позволяет определиться с вашими колонками и выбрать источник звука от моно звука (monaural) до системы совместимой с dolby 5.1.

Doppler effect - реализует эффект доплера (например высота звука проносящегося мимо вас вертолета изменяется с расстоянием до него)

Hardware mixing - используется аппаратное микширование, оно позволяет достичь лучшего качества эффектов и меньше нагружать процессор.

Enable EAX 2.0 - при аппаратном микшировании становится возможным использовать режим EAX 2.0 (например для карт семейства Audigy или Nforce2 soundstorm) Режим действительно стоящий если у вас есть хорошие колонки 5.1 и достаточно мощный компьютер, так как этот режим дополнительно нагружает процессор. Зато вся гамма звуковых эффектов, эхо, помещения и так далее вам обеспечены.

Compatible Mode - В случае проблем с совместимостью и глюками звука, попробуйте установить галочку на этом пункте, авось поможет=) но в любом случае его использование это не есть правильно и должно быть лишь временной мерой. Выход в случае проблем - новые дрова, операционка или даже звуковая карта (вы ведь не собираетесь играй в этот шедевр на АС97 звуке?=)

Enable Music & Music Quality - Можно отключить музыку если вы хотите насладиться тишиной тропического острова (недолго). Здесь же можно настроить ее качество.

Вместо заключения:

Зная за что отвечает каждая из этих настроек вы сможете подобрать их под себя добившись максимальной производительности. Настройки из раздела Customize представляют собой консольные команды и переменные. Вы можете пробовать многие из них прямо во время игры. Познакомьтесь с каждой из них поближе и решайте сами чем жертвовать ради скорости. но ИМХО - лучше всего все-таки апгрейд=)

Crowe